32.22 Opkey Release – 5.67

The following new features have been implemented in this release of Opkey Web:

Merging Feature in Opkey

This new merging feature in Opkey will allow the users to merge the files and folders of the same as well as other domains effortlessly. Users can now right-click on the desired files or folders and select the option of Manual Merge to proceed with working with the feature.

Users can perform the merging on the step level of Function Library and Test Case. It can be done for the Input and Output Parameters and for the Custom Keywords.

To proceed with the Manual Merge feature, the user needs to provide the details of selecting the domain in which the merging needs to be done. The user selects the project which can be of the same domain as well as for a different domain. The user will also have to provide the credentials such as Username, Password, and Project, making use of which the merging will be done.

In the next window, the user can see the count of files, which will get merged. If there is no conflict between the source file and the destination file, the user can view all the function library/business components and test cases in the tree hierarchy which need to be merged. From here the user can select the files and Merge them. If a conflict arises between source and destination files, a conflict window will be displayed to the user.

For fetching the project where merging is required user can face three scenarios:

  1. The user does not have the credentials for the domain to proceed ahead with the merging of the files.
  1. If the user possesses the credentials of the domain where merging needs to be done but may have limited access to the domain and its files and folders. In that scenario, the user will have to ask for the credentials from the respective admin user. The user will be asked to change the credentials and pick credentials that are not restricted to any file at the destination project.
  1. Users will not be able to proceed with the merging option if the files are in Freeze state, Unsaved mode, or Restricted to use. The user will have to first resolve the current states of the files and then proceed with the merging. However, the user will not be able to resolve the restricted state. For the rest two states, the resolve button does the resolution by fixing the required changes. Post these modifications, merging of the files will take place.

The user will first have to verify the credentials, for the permissions to change the states of files on the destination folder to proceed with the merging option. If the provided credentials do not have the rights and permissions, then it has to be replaced with the one which has those permissions. Users will have to go back and provide a different credential and then move ahead to resolve the conflicts for the merging to happen.

Users will then be able to click on the Manual Merge option, which will allow them to view the files of both source and destination together in a single window. This will assist them in selecting the files or steps in files that need improvement or modification. With files at both source and the destination opening up in a single window, eliminates the task of going back and forth and analyzing the required changes to be carried out.

The modifications or improvements can be done in the step level of Test Cases, Input and Output Parameters of Function Library, and Custom Keywords. Users can make the improvements and have a view of them in the same window and decide whether to proceed ahead or not. In case the desired outcome is not as per the expectation, the user can go back to the same scenario by clicking on the Reset button.

The Resolve button will get the improvements or modifications resolved, post which the user can select the Merging option. This will transport the selected files and their input and output parameters or any custom keywords.

The manual merging page consists of buttons:

Create – The user can create a particular artifact in the destination folder from the source folder if unavailable with the create button.

Merge – On clicking the merge button on the merge window user can manually merge the artifact’s step, input parameter, output parameter, and custom keywords. The defined hierarchy to be followed while merging the files is from lower to higher components.

Auto Merge – This will assist the user in merging all the files from the source to the destination folder in one go.

Finish – When all the files from the source to the destination folder are merged and are verified with a tick sign, the process can be completed with the finish button.

Post selecting the artifact, when the merge button is clicked, a new window opens up.

Source File – In this section, all the step data of the artifact present on the source project will be displayed.

Destination File – In this section, all the step data of the artifact present on the destination file will be displayed.

Merged Artifact Preview – In this section, the preview of the result of actions of manual merge performed using either of the tabs i.e Use Source File, Use Destination File, Auto Merge, and Merge can be seen. Merge can be further divided into Use this or Use both.

The available tabs in the window are:

Use Source File – It will manually merge all the scripts of the artifact from the source project to the destination project.

Use Destination File – By clicking on the button there will be no change on the artifact present on the destination project.

AutoMerge – It will merge all the scripts of the artifact present on the source project to the destination project automatically

The difference between Automerge and Use Source File is that with Automerge along with the Source File steps the additional steps will also be visible.

Merge – This functionality does a step-level change on the script of an artifact from the source project to the destination project.

This feature functions for both step levels i.e Use this step and Use Both Steps.

Use this step – It will move the selected step of the script of an artifact present in the source project to the destination project.

On doing Use both steps it will have the checked steps from both source file projects as well as destination file projects.

Use both steps is further divided into the Source step first and Destination step first.

Reset – This functionality will clear all the actions performed on Manual Merge and will keep the steps as it was earlier.

Resolve – This button will let the user resolve the actions performed on the manual merge window.

Adding Workday Logo in the BPMN view

Similar to other ERP logos in the BPMN view in our Surge platform, now we have implemented the Workday logo also.

Logo Change of Opkey

Opkey portal will now have a new logo replacing the old logo of Opkey.

Used Global Variable to get synced

This feature is related to the Import and Export of Opkey Projects. Now the mapping of Global Variable has been done at Coded Function Library, which will allow exporting only the used Global Variables in a Project. So now when the Global Variable is used in the Coded Function Library, only those Global Variables will be mapped by selecting from the Used By tab present on the Global Variable. The unused ones will not be exported.

The required Global Variables will be exported which the user can utilize for either syncing or as per their requirements.

Option to delete unused GV from the UI

This feature will allow the user to delete the unlinked Global Variable which is not used in any Function Library or Test Case, which saves them to get exported along with the Project.

Keyword to count the LDR Rows at runtime

GetLDRDataSetRowCount – This keyword is implemented for LDR which gets the count of the added data rows present in the currently executing data set iterations.

Test Case Report(Pre and Post Execution)

Now users can prepare Pre and Post Test Case reports in an excel file. The Sample Field will have details that the user needs to add to the sample Test Case Report, which can be downloaded in Excel File. The sample Test Case Report will then be uploaded to the upload section and a Post Execution Report in excel file can then be derived post that.

In the Opkey Recorder, we have updated the spy feature. Now the Objects can be spied using Alt + Hover

Agent File Update

Users will now get the Driver update automatically for the browsers while launching and relaunching the Opkey Agent. Users can also check for the updates in the Help tab present on the Opkey Agent for any new updates. The Driver update can be viewed and updated if any.

Appium Plugin

Appium_SwipeToObjectByPercentage

This keyword is used to swipe to a particular object. It takes the object, direction, and screen percentage as input arguments.

Three arguments have been provided for this keyword.

Direction – This argument will help the keyword to swipe to the object in the specified direction.

From Percentage – This argument helps to provide the device screen percentage from where we want to swipe on the screen.

To Percentage – This argument helps to provide the device screen percentage to where we want to swipe on the screen.

Keyword Appium_SetCustomPickerValue

This keyword is used to set the required value on the picker. This keyword takes one object, direction, and percentage as an Input Argument.

Opkey Mobility Android

We’re releasing a new instrumentor in this release.

Major Bug Fixes

Applications crashing issue fixed for many applications.

Mobicast and Screenshots bug fixed for Android Version 11

Bug fixes done for Mobile_WaitForObjectDisappear Keyword

Test Discovery by Opkey

Instance Analyze – With this new feature in Opkey Test Discovery, users will now be able to add the specific Instance to analyze its processes. On one single instance, users will now be able to analyze all the processes of a specific application, providing a multi-variant representation of the flow of the actual business processes.

This will provide the user a clear picture of the as-is business processes from start to finish and unearth delays, missteps, and redundancies to boost efficiency and skip rework.

To proceed with Analyzing the applications, the user will have to select the respective application and create an Instance by providing the credentials. A new Instance can be created by clicking on the Settings tab as well as by visiting the specific application and clicking on the “Add Instance” button.

Once the instance is added, the user will be able to analyze the processes, connecting with a different instance. When the connection gets established, the user can analyze the processes of the respective application from the available list. It can be done by selecting the desired application to fetch the processes. The fetched processes can be viewed in the List View as well as the Flow Chart view.

Once the processes are received, the platform provides the option to automate them with the click of a button. When the automation is done, the user can run the process flow with the Run button. The automated scripts can be executed with the help of available agent options. Here, the user can find the available options of Locally Available Agent, Agent Pool, and Browser Cloud that will help in executing the flow of processes.

For any failed steps in the executions, the user can raise tickets

Note: To execute the flow, an automated test case is mandatory. Without automation of the test case, users will not be able to proceed with the executions.

Once the run gets executed, the user will be able to view the details of the executed run on the right-hand side of the screen. The available tabs to view details of the processes are All, Data, Activities, Automation, and Comments.

Tickets – Users will have to click on the respective ERP and view the Activities tab for the execution results. To log a ticket for any failed script, the user will have to click on the three dots and select the option of log a ticket and enter details of the step on the pop-up window to create the ticket. The created ticket will be visible under the Tickets Icon. The canvas will display the graph of the executed flow. Users can view the Ticket ID, map the tickets with the External Tool Status, view the Summary, its Description, Priority, Assigned to, and Objects Affected under the All section. Under the Analysis section, users will be able to view the Field Comparison and Impact Analysis. Once the issues are fixed, users can put their comments in the Comments section. The three dots present in the extreme left-hand corner will display the status of the ticket.

With each application, users will be able to view the flow as well as create them, once it is analyzed. Through the Create Scenario button, custom scenarios can be created with the application-specific business components, that are user-defined flows.

Scenarios are labeled into three categories, Custom, Suggested and Mined. The scenarios can be edited according to the requirements.

Automated – The scenarios that are automated are placed in the Automated Category.

Custom – The custom scenarios are user-defined flows that are created with the application-specific business components.

Suggested – The scenarios which the user suggests to be used for a certain task, are termed Suggested.

Mined – The mined scenarios are the ones that we fetch from the user’s application. It will display the path followed by users in their application.

Users will be able to view the components in the activity based on Tags, concerning the chosen application. Users can create a scenario by clicking on the “+” icon and selecting the option of “Create Scenario” which will be a Custom/Manual scenario. By default, the user will be able to view only two activities and will be able to edit the activity with the Edit button present in the scenario. When the scenario is in the Edit mode, the user will be able to “Add New Component” or “Add New Activity”. Users will be able to add multiple components to one activity. When a new activity is added to the scenario, a new component gets added to that activity with the same name.  A new, as well as an existing component, can be added by dragging and dropping the component inside an activity. The name of the component can also be renamed. On the right-hand side panel, the option is available to add steps manually or by recording, add keywords, call the respective function library, add data through data source in the Input parameters and output parameters, and also the objects from the tabs. The data provided can also be edited.

Under the Analyze tab, you’ll be able to execute the specific automated test cases. There are prerequisites that the user will have to adjust with the Settings Tab in the Run Settings to execute the test cases. To run the Test Cases with the Run Now Settings, either of the agents will have to be selected from Local Agent, Agent Pool, or BrowserLab Agent, and provide details of Build, etc. The executions of the automated test cases can be scheduled or queued either through Browser Cloud or through the Agent Pool. Under the Analyze tab, users will be able to execute the specific Test Case at a time. However, in the executions tab user will be able to Create Run List under the Runlist tab, where multiple test cases can be added and executed. While the executions are running, the highlighted steps can be viewed on the right pane. The executions with the blinking of the steps can be viewed live through VNC(Virtual Network Connection) Screen.

Reports

Under the Reports tab, users can Create Reports for the following:

Quarterly Certification Report

Coverage GAP Report

Impact Analysis Report

Test Run Report

Test Case Report

For the Quarterly Certification Report, users will have to enter details on the pop-up window of Report Type, Report Name, Instance, Release, and Choose Test Runs. The report can be created by selecting the Test Runs of the respective Instance. Once the Result gets created, users will be able to view the information on the Report. The Report will have details of the Scenarios and Test Cases that are present in the Test Run and their count of passed or failed steps. The Report will also have details of the Modules concerning the chosen ERP application. The Affected Objects section will have details about the Objects that are impacted. On clicking the left side panel and selecting the particular Report, the dropdown will display the modules of the application, the processes, etc.

The process graph displays the reports of the executed processes present in the Test Case Scenarios. The dark lines on the graph represent the executed runs while the dim ones represent those scenarios that are not included in the execution. The Reports can also be downloaded in the PPT format, from the tab present on the right side window.

In the Coverage Report, the user needs to provide the name and select the Instance. This Report will have all the scenarios and test cases present in that particular instance.

In the Impact Analysis Report, users will have to compare the two releases to prepare the report. To fetch the Impact Analysis Report from the Reports tab, users will have to select the Impact Analysis report from the dropdown to create the report of the respective modules and run the instance to retrieve details of the impacted test cases. The report can then be downloaded from the right-hand corner of the page. The downloaded report will have the comparison of the pre and post-session data of the Test Cases of the cloud update.

In the Test Run Report, the user will have to provide the details of Report Name, Instance, and Choose Test Runs. Users will be able to view all the test run details in the reports of all the present scenarios and test cases based on test run selection.

The Test Case Report will have columns of Report Name, and Instance, which the user will have to fill in. To fetch the Test Case Reports, the user will have to click on the Reports tab on the left panel of the page. Users can now generate a Test Case Report from the dropdown arrow located on the right corner of the page. The generated report will have all the details of the scenarios and tests of the respective application.

Major Bug Fixes

Bug IDBug SummarySAS-47881Filetype LDR is not getting mergedSAS-47882Is default check box in LDR should also get merged along with the LDRSAS-47883Collection datatype is only taking default value when Fl called in FL/TC and also in simple FLSAS-47184Unwanted vertical scrollbar displayed on ANALYZE INSTANCE popup.SAS-46413Instance-view graph is not loading when the user selects the report node or module node on left pane after selecting the process node in the impact analysis report.SAS-45722when scenario or Test case is in edit state then in left panel if user hover on any field the UI of tooltip is not properSAS-47871AlM report there should be a space between Logo and the tableSAS-47869getting older Opkey logo in ALMSAS-47860not available to see images when zoom or minimize images at infinitySAS-47753Unable to select any of the context menu options if the selected scenario does not have any activity added in it on Analyze tab in Test Discovery.SAS-47542When execute healed scenario then running session name appeared delay after execution triggerSAS-47423Getting scheduled session in all instance instead of created instance onlySAS-47388Secure string data not appeared in masked form in data tab after select scenarioSAS-47294After delete dynamic object property then focus should be on next one objectSAS-47276In flowchart view called FL parameter default value not appeared and if select default value then getting validation messageSAS-47173Unable to get reporter , creator , assignee name not appeared in drop down in Jira filter with cloud instanceSAS-46789unable to click on search button in comment tab in right panel after select test caseSAS-46581Activity/Coomponent name editing UI is not as per the expected UI inside graph on EDIT SCENARIO screen.SAS-46579DOCKER | Message Box || Tooltip is not coming on message box for Action, Object and Data columnsSAS-46572UI of edit field while editing activity or component should remain inside that node and should adjusted as per node’s size.SAS-46537Tickets || Comments || DropDown are not workingSAS-46514Opkey Recorder || User is not able to login to Opkey form Opkey Recorder AddonSAS-46503DOCKER || Steps should not be recorded when user clicks on the DOCKERSAS-46412Evolve Recorder | DOCKER || Delete Step in DOCKER is not workingSAS-46411Opkey Recorder | DOCKER || After clicking on Stop and Save recording button in DOCKER, steps are not getting saved in OpkeySAS-46410Normal Recorder | DOCKER || Selected Recording mode is not getting reflectedSAS-46401DOCKER | OracleFusion Recorder || OracleFusion Fetch Metadata Popup is not coming while user selects Oracle Fusion Recording modeSAS-46153Unable to Collapse Child node when session in running stateSAS-45922Scheduled/Queued session is not getting deleted even after completion of 12 hrSAS-45887Search , All and Custom drop down for sorting or filtering is not working in comment tab right panel when user select a Test case or without selecting anythingSAS-45879when user add any comment then user have no option to delete or edit that comment in right panel when user select a scenario, Test case or without selecting anythingSAS-45865tooltip is not coming on download , setting and three dot button present in right panelSAS-45861when user select a scenario then in right panel “Data” and “Activities” top right corner , setting button is not workingSAS-45835Three dot button present at the top right corner of right panel is not working when user select a scenario, a test case or when nothing is selectedSAS-45788Multi Browser/Surge/OpkeyWeb Trigger run appeared in evolve Execution TabSAS-44868Unable to decrypt value in Surge In TCSAS-47884Exception appearing while clicking finish and automerge in merge artifact window || multiple keywords are get created in backend when clicking save in custom keywordSAS-47876“CONFLICT WINDOWN OPEN/TAB ALREADY open” while click on the manual merge |SAS-47885Opkey On Chrome | Browser Cloud Execution | Session is getting deleted when we are triggering execution on Browser cloud platformSAS-47886Opkey new logo || Latest Plugin || Mobility iOS || iOS device option is disabled if we run execution through pcloudy with mobility iOS plugin