1. Home
  2. OpKey Help
  3. 33. OpKey Policy

33. OpKey Policy

Backward Compatibility Policy of OpKey

This policy explains about the backward compatibility of the OpKey components. While working with OpKey Web, OpKey users should be aware about the backward compatibility of its supporting components (utilities & tools).

OpKey users are recommended to upgrade their OpKey Web environment to the latest released version. Furthermore, they should also upgrade their supporting OpKey components (like OpKey Agent, Plugins, Hub, Smart Recorder etc.) to use latest features and optimized test performance.

The main OpKey components are as follows:

  • OpKey Web
  • OpKey Agent
  • OpKey Plugins
  • OpKey Hub
  • OpKey Smart Recorder

If you are working on the OpKey version 5.57 (on-premise & cloud) then you can use the following version of the supported OpKey components:

  • Supported OpKey Agent version: 5.57
  • Supported OpKey Plugins version: 5.57
  • Supported OpKey Hub version: 5.57
  • Supported Smart Recorder version: 5.57

Note:

  • We always recommend OpKey users to use the latest OpKey version along with the corresponding supported OpKey components.
  • For OpKey on-premise users, we support OpKey Web & components up to 2 old versions from the current released OpKey version (i.e. current released version-2). For example, if the current/latest released OpKey Web version is 5.57 (on-premise) then we support OpKey versions 5.56 & 5.55 only.
  • You must ensure that you are using the same version of OpKey Web and the other supporting components (OpKey Agent, OpKey Plugins, OpKey Hub, OpKey Smart Recorder etc.).
  • In case of upgrading OpKey Web environment, you need to download and install the OpKey components of the corresponding OpKey Web version.
  • In case of using mismatched (incompatible) version of OpKey components, you might face unexpected issues while working on OpKey Web.

 

Was this article helpful to you? Yes No